MultiMedia Soft forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

SMF - Just Installed!

Author Topic: VIDEO BLACK  (Read 244 times)

pcuevas

  • Newbie
  • *
  • Posts: 12
    • View Profile
VIDEO BLACK
« on: October 28, 2019, 06:06:42 PM »

Hello Severino,
I'm running into troubles trying the mothod VideoWindowAdd works, no video is showing in the window. i had done some settings in lav video app. With some changes in hardware decoder, the video shows up in the window, but when the video is loaded and next line is VideoPlayer.Play no video is shown. However, if i use the mixer everything works fine in the mixer window. Same situation happeds with the demo app included (VideoMixer.exe ), mixer is fine, but the primary windows is black.  What do i missing?.

Regards,
Patricio
Logged

Administrator

  • Administrator
  • Sr. Member
  • *****
  • Posts: 298
    • View Profile
    • MultiMedia Soft
Re: VIDEO BLACK
« Reply #1 on: October 29, 2019, 12:06:15 AM »

Hello Patricio,

the reason could be an incompatibility between one of the transform filters used for managing output on multiple screens (named "InfinitePinTee") and the video driver. This may sometime due to the color space used in output by the LAV video decoder.
U
nfortunately our component doesn't have control over the output format of the LAV decoder so there may be the need to make some fine tuning inside the properties page of the LAV decoder itself; we would try the following:
1 - inside the Windows "Start" menu select "K-Lite Codec Pack/Codec Tweak Tool"
2 - inside the "Configuration" section press the "DirectShow filters" button
3 - under the "Video decoders" column select the "LAV video decoder" button
4 - on this page you will find a number of checkboxes inside the "Output formats" groupbox, each indicating a different output format
5 - on our system the "YV12" format seems to be the default so we would try to uncheck the "YV12" checkbox and press the "Apply" button without closing the page
6 - now try to reload the video using our component and see if it works; if it shouldn't, you may try to uncheck other check boxes until the problem disappears: we would live the "YUY2" checkbox checked which, at least here, seems to work correctly: please, don't forget to press the "Apply" button each time you uncheck one or more checkboxes

Hope this helps

Kind Regards

Severino Delaurenti
MultiMedia Soft
Logged