MultiMedia Soft forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

SMF - Just Installed!

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - PatrickVossen

Pages: [1] 2
1
Hi Severino,

My apologies for the late response.
The issue occurred out of the blue and also was solved out of the blue.
I guess that the radio-stream provider had updated something that wasn't working correctly.
After 1.5 week every stream was started instantly.

Best regards
Patrick Vossen

2
Hi Severino,

I have the issue on production systems where the AdjMmsEng.dll has version 13.1.0.2
I also have the issue on my development system where the AdjMmsEng.dll has version 13.1.1.6

I have checked it again because you did not have any problems:
- First try, timeout
- Second try starts within half a second
- 3th try took about 4 seconds but no timeout

I am going to see if raising the timeout value and updating to latest AdjMmsEng.dll improves it...


Best regards
Patrick Vossen

3
Hi Severino,

One of the thing where we use MMS for, is playing internet radio.
This always works without any issues.
But as of today the engine cannot open the streams any more and the control returns a stream_load_fail.
When I open the link in a browser (Chrome or Firefox) or in VLC, the links still can be played.
I guess that the provider changed something what results in a not able to open the stream using MMS

Do you have a more detailed reason for this stream_load_fail result?

One of the links for the radio station is https://20133.live.streamtheworld.com/RADIO10.mp3

Best regards
Patrick Vossen

4
Hi Severino,

Thanks for this.

Have a nice day

5
Hi Severino,

For starting the playlist, I have tried :
        AudioDjStudio1.PlayListExecute(Player_1, True)
        AudioDjStudio1.PlayListExecute(Player_1, False)
        AudioDjStudio1.PlayListExecAt(Player_1, IndexOrder(0))
        AudioDjStudio1.PlayListExecAt(Player_1, 0)

I have added my vb code and the playlist (.pdj) I have used

Code: [Select]
Imports AudioDjStudio

Public Class Form1
    Private Const Player_1 As Short = 0

    Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
        Dim ofd As New OpenFileDialog With {
            .Filter = "Playlist formats (*.m3u;*.pls;*.wpl;*.pdj)|*.m3u;*.pls;*.wpl;*.pdj|M3U PlayList (*.m3u)|*.m3u|PLS PlayList (*.pls)|*.pls|WPL PlayList (*.wpl)|*.wpl|PDJ PlayList (*.pdj)|*.pdj|All files (*.*)|*.*",
            .InitialDirectory = AudioDjStudio1.SoundsDirectory
        }
        If ofd.ShowDialog() <> DialogResult.OK Then Return

        If AudioDjStudio1.PlayListLoadSync(Player_1, ofd.FileName, enumPlayListModes.PLAYLIST_AUTOMATION_MODE) <> enumErrorCodes.NOERROR Then
            MessageBox.Show("Error loading playlist")
            Return
        End If
    End Sub

    Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
        AudioDjStudio1.InitSoundSystem(1, 0, 0, 0, 0, -1)

        AudioDjStudio1.PlayListSetLoop(Player_1, False)
        AudioDjStudio1.PlayListSetShuffle(Player_1, True)
    End Sub

    Private Sub AudioDjStudio1_PlayListLoadDone(sender As Object, e As PlayListLoadDoneEventArgs) Handles AudioDjStudio1.PlayListLoadDone
        Debug.WriteLine($"AudioDjStudio1_PlayListLoadDone   nPlayerIndex={e.nPlayerIndex}   bSuccess={e.bSuccess}")

        Dim Quantity As Short = AudioDjStudio1.PlayListGetCount(Player_1)
        Dim IndexOrder() As Short
        If Quantity > 0 Then
            ReDim IndexOrder(Quantity - 1)
            Debug.WriteLine(AudioDjStudio1.PlayListExecOrderTableGet(Player_1, IndexOrder, Quantity).ToString)
            Debug.WriteLine("+++++++++++++++++++++++++++++++")
            For index As Integer = 0 To IndexOrder.Length - 1
                Debug.WriteLine(IndexOrder(index))
            Next
            Debug.WriteLine("+++++++++++++++++++++++++++++++")
        End If
        AudioDjStudio1.PlayListExecute(Player_1, True)
        'AudioDjStudio1.PlayListExecute(Player_1, False)
        'AudioDjStudio1.PlayListExecAt(Player_1, IndexOrder(0))
        'AudioDjStudio1.PlayListExecAt(Player_1, 0)

    End Sub

    Private Sub AudioDjStudio1_PlayListLoadPerc(sender As Object, e As PlayListLoadPercEventArgs) Handles AudioDjStudio1.PlayListLoadPerc
        Debug.WriteLine($"AudioDjStudio1_PlayListLoadPerc   nPlayerIndex={e.nPlayerIndex}   nPercentage={e.nPercentage}")
    End Sub

    Private Sub AudioDjStudio1_PlayListLoadStart(sender As Object, e As PlayerEventArgs) Handles AudioDjStudio1.PlayListLoadStart
        Debug.WriteLine($"AudioDjStudio1_PlayListLoadStart   nPlayerIndex={e.nPlayerIndex}")
    End Sub

    Private Sub AudioDjStudio1_PlayListDone(sender As Object, e As PlayerEventArgs) Handles AudioDjStudio1.PlayListDone
        Debug.WriteLine($"AudioDjStudio1_PlayListDone   nPlayerIndex={e.nPlayerIndex}")
    End Sub

    Private Sub AudioDjStudio1_PlaylistSoundLoaded(sender As Object, e As PlaylistSoundLoadedEventArgs) Handles AudioDjStudio1.PlaylistSoundLoaded
        Debug.WriteLine($"AudioDjStudio1_PlaylistSoundLoaded   nPlayerIndex={e.nPlayerIndex}   nItemIndex={e.nItemIndex}   strTag={e.strTag}")
    End Sub

    Private Sub AudioDjStudio1_PlayListSoundLoadFailure(sender As Object, e As SoundLoadedEventArgs) Handles AudioDjStudio1.PlayListSoundLoadFailure
        Debug.WriteLine($"AudioDjStudio1_PlayListSoundLoadFailure   nPlayerIndex={e.nPlayerIndex}   nItemIndex={e.nItemIndex}")
    End Sub
End Class

6
Hi Sererino,

Thanks for you explanation.

Grtz Patrick

7
Hi,

Retrieving the shuffled playlist order does not seem to work.

I have a playlist that's loaded from .pdj file containing 3 files (using PlayListLoadSync, PlayListLoad does not seem to work at all).
The PlaylistSetShuffle option is set to true (was already set before loading the pdj-file).
On the PlayListLoadDone-event, I do a call to PlayListExecOrderTableGet to retrieve the PlayOrder.
Result for this is    2 - 1 - 0
The playlist starts playing and on the PlaylistSoundLoaded-event I log the indexes that are played.
The result for this is    2 - 0 - 1

Grtz
Patrick Vossen

8
Hi Severino,

We are using the MMS engine for playing (streaming) mp3 files from several network locations.
Some customers experience errors where the engine returns STREAM_LOAD_FAIL on loading the stream.
Is there a way to get the real error (404 or timeout or something else) instead of the generic message STREAM_LOAD_FAIL?

Best regrards
Patrick Vossen

9
Hi Severino,

I noticed when creating a playlist file (.pdj), the complete path is used.
Is there a way to only use the filename in the .pdj file and set the soundsdirectory for the control?

Best regards
Patrick Vossen

10
Audio playback and audio management components / Re: files for Playlists
« on: February 15, 2021, 09:09:33 AM »
Hi Severino,

Thank for the info.

Best regards
Patrick Vossen

11
Audio playback and audio management components / files for Playlists
« on: February 04, 2021, 03:17:22 PM »
Hi Severino,

I am trying to create a playlist-file (wpl or pdj) for using with the ADJ component, but I noticed that, when adding a filename with an &-sign in the filename, the file is not found by the control and removed from the playlist.
When manually creating a playlist with the demo application and saving the playlist I notice that the &-sign is saved as &amp;
Is there a list what chars needs to be converted to html entries (e.g. the space is NOT converted to &nbsp;)

Best regards
Patrick Vossen

12
Hello,

I've got some questions;
  • When I set drivertype to WASAPI, does the videoplayer also use the wasapi driver type?
  • Does it make any difference what audio_render_mode is used? I am using the AUDIO_RENDERER_MODE_CUSTOM_2

Best regards,
Patrick Vossen

13
Hi Severino,

Is it possible to cancel an fade-out action after setting the StreamVolumeSmoothingSet-function?
I noticed that when setting
Code: [Select]
audioDjStudio1.StreamVolumeSmoothingSet(e.nPlayerIndex, False, 5000, enumVolumeCurves.VOLUME_CURVE_LINEAR, -1)And calling
Code: [Select]
audioDjStudio1.StopSound(Player_A)The player starts to fade out (=OK), but then when I want to stop the song during the fade-out time, I can call
Code: [Select]
audioDjStudio1.StreamVolumeSmoothingSet(e.nPlayerIndex, False, 0, enumVolumeCurves.VOLUME_CURVE_LINEAR, -1)And calling 'StopSound' again, the song directly stops, but when I start the song again, the first Fade action is continuing to Fade-out.

Is there a way to cancel this Fade-out action?

Best regards
Patrick Vossen


14
Hi Severino,

Thanks for your response.

I have been testing what caused this and I found the cause.
The issue happens on W10 where 2 monitors are connected, the main monitor is VGA/onboard connected (Intel HD Graphics 630) and the second screen is connected using NVidia NVS 310.
The video application needs to be running on the 2nd screen and the audio application on the main screen.
The Nvidia card is running latest driver but the Intel display is NOT running on a recent driver because the OS is W10 IOT 2015 and the latest driver for the Core i3 processor that can be installed on such an old OS is a 2016 driver. (and IOT does not allow mayor updates)
A workaround is to start another video screen on the main monitor and load a video file into it and pause this one.

Grtz Patrick

15
Hello,
We have noticed a crackle/tick in the sound when loading a videofile into the engine.
This occurs on several W10 systems with several soundcard types. (onboard/usb/pci)
I guess that this tick is in the soundcard, not in the application, I also noticed it when listening to internet radio in Chrome browser and when loading a MP4 (AAC/AVC) into the MMS engine the crackle occurs. The used codec is latest KLite (LAV) but also on W10 codecs.
I have checked and issue occurs with AdjMmsEng v10.7 but also with v13.1.1.6.

Has someone a solution for this?
Grtz Patrick Vossen

Pages: [1] 2